fastjson < 1.2.67 反序列化和SSRF漏洞

回复
头像
雷雨
荣誉元老
荣誉元老
帖子: 501
注册时间: 2017-02-13 11:34

fastjson < 1.2.67 反序列化和SSRF漏洞

帖子 雷雨 »

fastjson官方git披露fastjson存在最新反序列化远程代码执行漏洞攻击Gadgets,利用该最新的Gadgets,攻击者可以造成远程命令执行,或者造成SSRF漏洞,风险较大。官方已发布最新版本1.2.67修复该漏洞,请使用到fastjson的用户尽快升级至安全版本。

漏洞描述

fastjson采用黑白名单的方法来防御反序列化漏洞,导致当黑客不断发掘新的可攻击的反序列化Gadgets类时,则可能可以绕过黑白名单防御机制,造成远程命令执行或者SSRF漏洞。烈火云应急响应中心提醒fastjson用户尽快采取安全措施阻止漏洞攻击。

影响版本
fastjson < 1.2.67
fastjson sec版本 < sec09

安全版本

fastjson >= 1.2.67
fastjson sec版本>= sec09

安全建议

注意:较低版本升级至最新版本1.2.67可能会出现兼容性问题,建议升级至特定版本的sec09 bugfix版本
回复